Quantcast

Twonky server puzzle

Discussion in 'Google TV Help' started by mwphelps, Aug 17, 2011.

  1. mwphelps

    mwphelps New Member

    Joined:
    Aug 2, 2011
    Messages:
    12
    Likes Received:
    1
    Trophy Points:
    0
    Any help with this would really be appreciated.

    The gear:
    Ubuntu (Lucid Lynx) on older Toshiba laptop - CAT5 to Linksys WRT54G
    Running Twonky
    Logitech Revue - WiFi from WRT54G

    (Disclaimer: I'm not much of a Linux guy. I tinker. When the laptop in question went blort with Windows, Ubuntu rescued it. I don't have a Windows box available to me at this point.)

    The Problem:
    From the Revue I can see most of the vids stored on the laptop. A few won't play...that's probably a format issue I can fix. However, the ones I can get started only stream the soundtrack...no video picture. That's the puzzle. Sound yes; picture no.

    Thoughts?
     
  2. eferz

    eferz Well-Known Member

    Joined:
    Nov 4, 2010
    Messages:
    3,301
    Likes Received:
    445
    Trophy Points:
    83
    If you got your Twonky server set to transcode then its possible that you don't have all of the ffmpeg components installed properly. You might want to check their support page and recheck your configuration.

    Otherwise, its probably that the video stream was encoded with an incompatible codec. Here's a list of the compatible video formats which was taken from their documentation on following support page. Below are the video formats which are currently compatible for Google TV in its current form, though apparently there will be more support in Android 3.1.

    File ContainerVideo StreamAudio StreamText Stream
    .MKVH.264/MPEG-4 AVCAACNA
    .FLVH.264/MPEG-4 AVC and H.263AACNA
    .MTSH.264/MPEG-4 AVCAACNA
    .MT2SH.264/MPEG-4 AVCAACNA
    .TSH.264/MPEG-4 AVCAACNA
    .AVIH.264/MPEG-4 AVC, DivX MPEG4, and Xvid MPEG4AACNA
    .MOVH.264/MPEG-4 AVCAACNA
    .MP4H.264/MPEG-4 AVCAACNA
     
    • Like Like x 2
  3. svtfmook

    svtfmook New Member

    Joined:
    Aug 15, 2011
    Messages:
    12
    Likes Received:
    1
    Trophy Points:
    0
    you have to edit the config file to point to the ffmpeg libraries.

    make sure you have ffmpeg libraries installed (you can copy these commands and paste them into terminal, first one is long, make sure you copy it all)
    Code:
    sudo apt-get install libavcodec-unstripped-52 libavdevice-unstripped-52 libavformat-unstripped-52 libavutil-unstripped-49 libpostproc-unstripped-51 libswscale-unstripped-0 ffmpeg
    then you can change the ffmpeg location:
    Code:
    sudo gedit /usr/local/twonkymedia/cgi-bin/ffmpeg.location
    if it says "c:\\ffmpeg", change it to "/usr/bin", save, exit

    transcoding may need to be enabled to run in the foreground, you have to edit the startup script to get that to work.
    Code:
    sudo gedit /etc/init.d/twonkyserver
    change the line "$TWONKYSRV -D" to "$TWONKYSRV"
    restart the server and it should

    if you have trouble editing the ffmpeg location or twonkyserver script, try changing "gedit" to "nano" in the commands.
     
    • Like Like x 2
  4. mwphelps

    mwphelps New Member

    Joined:
    Aug 2, 2011
    Messages:
    12
    Likes Received:
    1
    Trophy Points:
    0
    Will attend to this shortly. Thanks so much!

    FWIW: I just bought a Sony Google TV, and it plays the material in question without a hitch.
     

Share This Page