Quantcast

Revue Dead?

Discussion in 'Logitech Revue' started by SourDieseL, Jun 7, 2011.

  1. SourDieseL

    SourDieseL New Member

    Joined:
    Apr 19, 2011
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    0
    Hey all so it's been about a month or two since I had my googleTV / Revue. Although I wasn't super impressed with it, I was optimistic about the new upgrades and app store, etc. I had my netflix running off of it no problem as well.

    Unfortunately, a few days ago, I went to turn my TV on and noticed my revue LED was off. It was plugged in and all and it just seemed to have died completely. I don't know why, it just doesn't turn on.

    I held the power button in the rear right back by the inputs and still nothing. I reset my power strip and all my other devices on the power strip work so it couldn't be that. I disconnected the power to the revue and it still doesn't power on.

    Anyone with any ideas? Anyone else have this happen to them?
     
  2. sparkyscott21

    sparkyscott21 Moderator Staff Member

    Joined:
    Nov 4, 2010
    Messages:
    7,280
    Likes Received:
    103
    Trophy Points:
    63
    Location:
    Northern Mich.
    Maybe try to leave it unplugged for 5 minutes or so, and try plugging it in in another outlet..

    Sorta a double try if you will....
     
  3. galfert

    galfert Active Member

    Joined:
    Jan 22, 2011
    Messages:
    315
    Likes Received:
    42
    Trophy Points:
    28
    Location:
    Orlando, FL
    The button in the back is not a power button. That button is used to pair keyboards and controllers. The Revue doesn't have a power button...you just plug it in and it is on all the time.

    Sounds to me like your unit is dead. Call Logitech and return it for warranty repair/replacement.
     

Share This Page

Search tags for this page

logitech google tv dead