Quantcast

Plex for Google TV - lagging streams

Discussion in 'Google TV Apps' started by ramsix, Apr 15, 2012.

  1. ramsix

    ramsix New Member

    Joined:
    Apr 15, 2012
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    0
    Hey guys,

    i posted about this problem on the plex forums, but its taking really long and there are no replies :(
    so i was hoping someone from here knows about this issue and can help.

    so plex media player on GTV has a really nice interface and its verry easy to use. in my setup, i have my desktop pc running plex media server with all my audio/video files loaded up onto the Plex media server.
    on my Google tv, i can connect to the PMS fine and all my videos show up, everything seems good.

    however, when i play any of my videos, the video plays for about 5-10 seconds, and then stops for about 10-15 seconds, and then plays for another 3-5 seconds, stops, and this jsut keeps happening. this is really wierd because i run an alternate media server using windows media player sharing and all the videos play perfectly fine without any issues on the default Media Player app on GTV.....

    to fix this problem, i had found out that if i force "direct play" on the videos im watching, the videos start to play normally without any hiccups, but the issue with direct play is that when i force direct play on a video, then if that video has multiple audio streams or subtitles, i cant select which audio stream i want to play, and if i select a subtitle, it still doesnt change... it just plays one default audio stream and no subtitles for that video and never changes nomatter how much i try, when direct play is forced on that video.
    If i play the video without direct play, the video can then play with whichever audio stream i choose. It even plays with subtitles if i select subtitles to be displayed. But then the issue is that when i play the video without direct play, the videos start to lag again just like before! :(

    Does anyone have any idea how i can play any video i want on plex, without any lagg, and with the ability to select the audio stream i want and then the video to play properly with that audio stream without any lagg?

    All my videos play fine on the GTV Media player, so i know they work.... but i just want to use Plex cuz its so much nicer, and it has the option to choose different Media tracks/streams for the video and to enable subtitles........ but i cant figure out how to get them to work properly without lagging! >.<
     
  2. mcd2000

    mcd2000 Active Member

    Joined:
    Nov 16, 2011
    Messages:
    380
    Likes Received:
    54
    Trophy Points:
    28
    Location:
    Saint-Petersburg, Russia
    In HLS mode Plex Server transcodes both video and audio from your movie. Your PC could be simply not powerful enough to do this.
     
  3. ramsix

    ramsix New Member

    Joined:
    Apr 15, 2012
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    0
    its wierd... my comp has a i7-2600k processor with 16GB RAM, 5870 Radeon Graphics with 1GB.
    that should be pretty good for doing the transcoding normally right? is there something that i might be missing?
     
  4. mcd2000

    mcd2000 Active Member

    Joined:
    Nov 16, 2011
    Messages:
    380
    Likes Received:
    54
    Trophy Points:
    28
    Location:
    Saint-Petersburg, Russia
    Yep. :)
    It should be something else then...
     
  5. ramsix

    ramsix New Member

    Joined:
    Apr 15, 2012
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    0
    but what could be the reason? whats the difference between direct play and HLS over the air transcoding?
     
  6. xlightwaverx

    xlightwaverx New Member

    Joined:
    Jan 17, 2012
    Messages:
    21
    Likes Received:
    1
    Trophy Points:
    0
    Location:
    New England
    Every time I try HLS Transcoding it says my device doesn't support it, so I am forced to use Direct Play which, unfortunately, directly plays the file without transcoding it to a more user friendly format. I thought GTVBox Player would pick up the DNLA but that isn't working either.

    Every forum I have checked that deals with this issue points to the Logitech Revue's software not being able to handle the HLS Trancoding, and labeling that is the issue of the problem. Note: This is only .mkv format. The other's appear to being working well.

    Please advise.
     
  7. mcd2000

    mcd2000 Active Member

    Joined:
    Nov 16, 2011
    Messages:
    380
    Likes Received:
    54
    Trophy Points:
    28
    Location:
    Saint-Petersburg, Russia
    GTVBox works with Plex Server as DLNA client, but still without trancoding yet.
    I am looking into creating profile for Plex Media Server to support transcoding for GTVBox.
     
  8. ramsix

    ramsix New Member

    Joined:
    Apr 15, 2012
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    0
    I have heard that GTVBox can support audio stream selection for videos.
    Is this possible to do?
    like if i have a video with 3 diff audio streams, can i select whichever one i want and watch the video on my GTV, streaming it thru my media server on the PC?
     
  9. ramsix

    ramsix New Member

    Joined:
    Apr 15, 2012
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    0
    Hey, i think u should check if there are any device updates for the revue... im not sure but it sounds like u havent gotten the update in order to allow for HLS support.... or maybe it has not been released for revue 0.o .. im not too sure
     
  10. mcd2000

    mcd2000 Active Member

    Joined:
    Nov 16, 2011
    Messages:
    380
    Likes Received:
    54
    Trophy Points:
    28
    Location:
    Saint-Petersburg, Russia
    Yes. This is possible, but only if the file itself is compatible with Revue.
     
  11. ramsix

    ramsix New Member

    Joined:
    Apr 15, 2012
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    0
    how can i get the same functionality to work on Plex? apparently the functionality is there, and it shud work fine, but when i play a video with a different audio stream of my choice, it just plays and laggs every few seconds, but if i play directplay with the default audio, it plays fine....
     

Share This Page

Search tags for this page
android tv plex lagging
,
plex lagging tvbox
,
plex laging
,

plex video lag