Quantcast

PCM issue with A/V receiver - manually select codec on receiver

Discussion in 'Google TV Help' started by bdelamatre, Mar 12, 2011.

  1. bdelamatre

    bdelamatre New Member

    Joined:
    Mar 12, 2011
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    My Google TV does a great job with selecting the correct audio codecs while watching Blu-Ray. My issue is that it sucks at selecting codecs for everything else. It sends a PCM signal to my A/V receiver for Pandora, NetFlix, Podcasts, etc and when it does this my A/V receiver plays it at PCM quality and prevents me from selecting something else then PCM. What I would like it to do is let my A/V receiver do it's job with lower quality audio from these sources and 'upscale' the quality for DPLII which sounds much better.

    Example:
    I plug my Android phone directly into my receiver and play Pandora. Then on my A/V receiver I select DPLII and it sounds excellent. I select Pandora on my Google TV hooked into the same receiver and it forces it to use PCM which sounds terrible.

    The one workaround I have found is to play Pandora, exit Pandora, leave Pandora running in the background, select the TV input (I don't have a TV signal hooked up, so it just shows a black screen with no audio), then to hit the home page. What appears to happen is that the TV input works how I want it to, by letting me manually set the codec to DPLII, and since Pandora is still playing in the background it now magically uses DPLII instead of PCM. However if I enter any other application such as Chrome, it automatically sets back to PCM.

    I have a Sony NSZ-GT1 and Pioneer VSX-1020 A/V receiver. I have spent hours trying different configurations on the GT1 and my Pioneer and have tested the settings with HDMI and Optical audio. Any help would be much appreciated.
     

Share This Page

Search tags for this page

hr44-500 pandora problems