Quantcast

M2TS playback in Media Player in 3.1?

Discussion in 'Logitech Revue' started by pgoelz, Dec 12, 2011.

  1. pgoelz

    pgoelz New Member

    Joined:
    Sep 11, 2011
    Messages:
    43
    Likes Received:
    1
    Trophy Points:
    0
    So, after the update I tried to play my MTS videos (from a Canon HF100 camera, stored on a networked PC and served via Windows 7 DLNA) and they won't play. The Revue can see them and even displays an appropriate thumbnail with the PLAY icon over it for each video. But when I actually try to play them, I get a "cannot play video" error. I know it is kinda early in the Honeycomb / Revue experience but does anyone have any ideas? I thought MTS videos were supposed to be supported. And no, I don't want to transcode. I don't have quite enough processing horsepower to do that in real time. I was hoping the Revue would be able to use hardware decoding..... or is this a Honeycomb issue where it needs a codec?

    Paul
     
    Last edited: Dec 12, 2011
  2. eferz

    eferz Well-Known Member

    Joined:
    Nov 4, 2010
    Messages:
    3,301
    Likes Received:
    445
    Trophy Points:
    83
    MTS is a container format which describes how to interleave the individual streams. This is used to provide a linear a time line between the streams. The thumbnail that you're seeing could be "coverart" that your camera embedded into the container. As for the compatibility of the actual video and audio streams inside the MTS container that will vary upon the available codecs that is included with the Logitech Revue.

    Download MediaInfo to you determine the audio and video streams inside the container. If you're unable to understand or cannot decipher the information then copy and paste the information here. And we'll try to help you figure out why they aren't working.
     

Share This Page

Search tags for this page

add thumbnail to mts container