Quantcast

Chromecast Disconnects after 2 seconds

Discussion in 'Google Chromecast' started by yushi, Jan 10, 2014.

  1. yushi

    yushi New Member

    Joined:
    Jan 10, 2014
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    0
    So I got mine 2 days ago. I should mention that i am outside of US.
    I managed to setup Chromecast from my iphone. It connects correctly but when I start to cast from Chrome(pc) to it, after 2 seconds of casting it disconnects and chrome tells me to check if the device is online. in fact it is online and I can keep trying to cast , but always the same. So here is more info about my setup:
    - I am using an ADSL wifi router. Zyxel a/b/g
    - router is practically in the next room so chromecast has full bars
    - my cpu is i7 so it doesn't sweat casting from Chrome
    - I am on windows 7 64bit
    - I have tried casting from Galaxy s4 but after some 40 seconds of black screen on youtube it tells me that it can not connect to Chromecast.
    - I can only get one frame of chrome casting from my PC before it disconnects
    - I have tried this from a computer which is connected to router by wire, but the same thing happens

    anybody has this situation? any help please?
     
    Last edited: Jan 10, 2014
  2. revue5

    revue5 Well-Known Member

    Joined:
    Aug 1, 2011
    Messages:
    1,099
    Likes Received:
    206
    Trophy Points:
    63
    Hi,

    i haven't try CC outside of US.

    Give this a try, factory reset CC then unplug/replug power, run setup from Galaxy s4 - try it & see if that helps ...

    also, make sure to set channel (frequency) in router/AP between 1 ~ 11 (max).
     
  3. yushi

    yushi New Member

    Joined:
    Jan 10, 2014
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    0
    Hi revue5

    I actually could cast from galaxy s4 after all. Youtube works.
    but no luck with PC. I even tried new chrome 30 beta but the same situation.
    you think factory reset may work? How should i do it?

    thanks
     
  4. revue5

    revue5 Well-Known Member

    Joined:
    Aug 1, 2011
    Messages:
    1,099
    Likes Received:
    206
    Trophy Points:
    63
    Ok, if the issue now is only limited to the PC? Is the PC connected via wire or wifi?
    If wired, that should also work. however, you may need a separate router ( I think these ADSL all-in-one routers are problematic with PC>Ethernet)

    As fare as CC factory reset, you'll find the option in chromecast app. But now I'm not sure if that 'd help the PC issue?
    but you can always try to factory reset CC then unplug/replug power, run setup from the PC - try it & see if that helps ...

    I assume you installed "cast extension" add-on to Chrome - PC setup
    Also, check if a double "Flash Player" versions exist in Chrome.
     
  5. yushi

    yushi New Member

    Joined:
    Jan 10, 2014
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    0
    So i did some of the things you mentioned:
    - Disabled a flash player and enabled chrome flash player
    - I am on laptop and wifi
    - I downloaded chrome setup program for pc and factory reset the device and setuped again
    - i have the cast extension

    still the issue remains
    one thing that i noticed is that my firmware version is 12940 and it won't update. I think there is a new firmware.
    is there a way to manually update it?

    thanks
     
  6. revue5

    revue5 Well-Known Member

    Joined:
    Aug 1, 2011
    Messages:
    1,099
    Likes Received:
    206
    Trophy Points:
    63
    no manual update. just leave it on all time (usually gets it at late hrs).
    or, after factory-reset, re-setup may detect an update ...

    i think CC firmware ver now @ build: 14975 and Chrome beta @ 32+
     
    Last edited: Jan 13, 2014
  7. yushi

    yushi New Member

    Joined:
    Jan 10, 2014
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    0
    Any way
    casting from mobile phone works perfectly but no luck from PC.
    what a let down
     
  8. revue5

    revue5 Well-Known Member

    Joined:
    Aug 1, 2011
    Messages:
    1,099
    Likes Received:
    206
    Trophy Points:
    63


    Have a look at this ^ video / from 6:30^ (casting from CC via PC works fine).
    If you have a chance, try a different PC/Laptop or add a separate router to your current ADSL-combo-router (bridge settings required) - good luck.
     
    Last edited by a moderator: Jul 30, 2014
  9. yushi

    yushi New Member

    Joined:
    Jan 10, 2014
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    0
    i have tried different laptops. I'm going to try this at some friend's house with different router and see what happens.
    I hope pc cast comes out of beta sooner. maybe that would resolve the problem
     
    Last edited by a moderator: Jul 30, 2014
  10. revue5

    revue5 Well-Known Member

    Joined:
    Aug 1, 2011
    Messages:
    1,099
    Likes Received:
    206
    Trophy Points:
    63
    ^
    not sure what you mean by "beta"? unless you referring to "Tab Projection"(mirror)?

    (from PC/laptop) casting the following sites, work very well, btw.

    · Netflix ............................................. cast optimized site
    · YouTube ......................................... cast optimized site
    · Google Play Movies & TV .............. cast optimized site
    · Google Play Music ......................... cast optimized site

    cast optimized site /"Direct playback" (passes video directly from internet to TV) supports 1080p video, 5.1 surround sound (& stereo).
     
  11. yushi

    yushi New Member

    Joined:
    Jan 10, 2014
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    0
    I meant Tab casting. it says it is in beta.
    but any way... I got it working at last
    It seemed that Chromecast wasn't updating because it was outside of US.
    So I did this:
    - connected my laptop through ethernet
    - setup a VPN connection to US
    - setup an ad-hoc connection
    - setup chromecast to connect to ad-hoc
    - Updating started right away
    - disconnected everything and restarted everything!!
    - setup chromecast again to connect to my wifi
    - now tab casting works. I watch videos(not from youtube) and they don't have cast option. a bit of delay which is alright and occasional disconnections

    thanks
     

Share This Page

Search tags for this page
chromecast connects and then disconnects
,

chromecast connects then disconnects

,
chromecast disconnects
,
chromecast disconnects after a few seconds
,
chromecast disconnects from tv
,
Chromecast Disconnects from WiFi
,
chromecast disconnects immediately
,

chromecast keeps disconnecting

,
when i cast screen with chromecast it connects then quickly disconnects
,
why does my chromecast keep disconnecting